This topic has 3 replies, 2 voices, and was last updated 6 years by Kieran_SQ.

  • Author
  • #166706
     pebbleart
    Participant

    Hi team, when I am logged into my site as a user and I go to my profile fields, if I have added a multi line description, there is an option to click “text” and then there’s an “img” button. When I click that I’m prompted to add a picture url and if I do and switch back to visual mode I see the picture rendered. However if I click save it does not save the image.

    Can you tell me if this is a bug please? Thank you.

    I currently have this theme on a fresh wordpress install with only the recommended plugins activated.

    #166727
     Kieran_SQ
    Moderator

    Hi @Peebleart,

    As strange as it sounds that is the correct behavior for this element, it’s a BuddyPress feature and not related to KLEO.

    You may want to try this plugin https://wordpress.org/plugins/buddypress-xprofile-custom-fields-type/ which may do what you need.

    Hope this helps,

    Kieran.

    Hi there!!! Help others from the community and mark any reply as solution if it solved your question. Mark as a solution

    If you like the theme or the support you've received please consider leaving us a review on Themeforest!

    Custom development requests can be sent to dev@seventhqueen.com, one of the development team will be happy to discuss your needs.

    #166788
     pebbleart
    Participant

    Thank you very much for your reply. So the Buddypress feature is designed to let users put images on their profiles that then disappear when they save? That doesn’t seem to make sense. Wouldn’t it be better to just not have that feature or hide it? Does it have an actual purpose? Is it a thing that other themes employ?

    Thank you so much for your help, I’m just trying to understand.

    #166794
     Kieran_SQ
    Moderator

    Hi,

    From my understanding it’s an oversight with the editor they have used, it might be worth opening a ticket with BuddyPress with regards to this matter as it isn’t theme related. They’re allowing the input of HTML in a controlled way by using the editor, I can’t imagine they ever meant to use the image feature as it doesn’t fit the field type. You can hide it yourself if you wish with the following CSS added to your child theme’s style.css or in Theme Options > General > Quick CSS.

    COPY CODE
    input#qt_field_3_img {
        display: none !important;
    }

    And to solve the issue of the text area not being fullwidth in the text tab please use

    COPY CODE
    textarea#field_3 {
        min-width: 100%;
        max-width: 100%;
    }

    It’s worth giving the xprofile fields plugin a try, I feel like they may do this better. It’s up to you 🙂

    Thanks,

    Kieran.

    Hi there!!! Help others from the community and mark any reply as solution if it solved your question. Mark as a solution

    If you like the theme or the support you've received please consider leaving us a review on Themeforest!

    Custom development requests can be sent to dev@seventhqueen.com, one of the development team will be happy to discuss your needs.

Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘Bugs & Issues’ is closed to new topics and replies.

Log in with your credentials

Forgot your details?